The root cause has not been identified, we have decided to roll back the system to a known good state. CRM Web is now avaiable and functioning normally
Posted Mar 26, 2026 - 15:31 UTC
Investigating
We have identified an outage with CRM Web. It is currently inaccessible. We are currently investigating and will continue to provide updates.
Posted Mar 26, 2026 - 14:14 UTC
This incident affected: Marketscape CRM (Web App, API).